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Sequin Digitizing

Some embroidery machines are equipped with a sequin dispenser that drops 
sequins onto the garment as it stitches. EmbroideryStudio allows you to 
digitize sequined designs for compatible machines.

EmbroideryStudio also supports the creation of twin-sequin designs for 
twin-sequin-capable machines. There is also a dedicated tool for automatically 
converting sequin artwork in the form of a vector file to sequin runs.

Setting up sequin mode

Before you can use Sequin mode, you must select a machine format that 
supports it. You can then set up a dedicated sequin palette for your design from 
a list of predefined shapes and sizes. 

Barudan BEVY-Z1506C 
twin-sequin machine – devices 
are mounted on right and left 
sides of the heads
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Note  If you have selected Dahao as your machine type, Dahao twin-sequin DST 
file format is available on output. The Drop Sequin functions are inserted 
according to Dahao twin-sequin requirements.

Selecting a sequin-capable machine

Before you can use Sequin mode, you must select a suitable machine format 
via the Select Machine Format dialog. Sequin mode is supported in Schiffli, 
Tajima, Barudan, SWF, and ZSK embroidery machine formats. Support is also 
provided for the Tajima TBF and Barudan FDR-II twin-sequin machines to enable 
digitizing of twin-sequin designs. EmbroideryStudio also supports the Dahao 
controller used by many Chinese machines. One of these machine formats must 
be selected before twin-sequin runs can be created in EmbroideryStudio.

To select a sequin-capable machine
1 Select Design > Select Machine Format.

2 From the Available Machine Formats list, select a sequin-capable machine 
format – e.g. Schiffli, Tajima, Barudan, SWF, or ZSK.

3 Click OK. Sequin shapes are now available for selection from the Sequin 
Palette. If you have selected a twin-sequin-capable machine, sequin shapes 
and sizes are displayed in pairs.

Note  Different machines require different presets. Typical modifiable values 
include stitch and jump length, trim functions and color change functions. Use 

Select
sequin-capable
machine format

Click to adjust 
format

Twin-sequin palette Single-sequin palette
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the Machine Format Settings dialog to customize values if outputting to a 
specific machine format. 

Related topics
 Machine formats
 Exporting designs for machine
 Creating twin-sequin designs

Setting up sequin palettes

The Sequin Palette Editor lets you prepare a palette of sequins to use in your 
design. Set color and size for each sequin, as well as sequin hole size. Once set 
up, the palette is available for use from the Sequin Palette droplist.

To set up a sequin palette
1 Click the Sequin Palette Editor icon. Fields are arranged in tabular form so 

that parameters for each sequin type can be viewed at once.

Use Sequin > Sequin Palette to select from a user-defined palette of sequin 
shapes for the current design.

Use Sequin > Sequin Palette Editor to select shapes from a sequin library. 

Click to add 
sequin types
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2 Click the More button to create a new entry. Depending on the selected 
machine type – single or twin – a single or double column will be added to the 
Sequin Palette Editor. 

Tip  Click the X in the column header to remove any unwanted sequins.
3 Select a sequin type from the Sequin droplist.
4 Edit sequin colors and sizes as required. Size, Hole and Comment fields are 

all editable.

5 Repeat as many times as required and click OK. Sequin shapes are now 
available for selection from the Sequin Palette. If you have selected a 
twin-sequin-capable machine, sequin shapes and sizes are displayed in pairs.

Related topics
 Selecting a sequin-capable machine
 Creating twin-sequin designs

Visualizing sequin designs

Select sequin type 
from the droplist

Click to
select color

More colors available

Twin-sequin palette Single-sequin palette

Use View > Show Functions to toggle display of machine function symbols. 
Right-click for settings.

Use View > Show Stitches to toggle embroidery stitching display. Right-click for 
settings.
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Sequins can be viewed in TrueView or stitch view. 

Both sequins and fixing stitches appear in their selected colors and can be turned 
on or off via Show Functions and Show Stitches toggles.

When traveling through a sequin design, ‘undropped’ sequins appear in the 
‘unsewn’ color defined in the Background & Display Colors dialog. See 
Changing display colors for details. 

Creating sequin runs

EmbroideryStudio provides tools to create a string of sequins along a digitized 
line according to preset spacings or as marked by the digitizer. You can preset 
sequin type or change it at any stage. Similarly, you can preset fixing stitches or 
change them after digitizing.

Tip  The Show Repeats function displays repeating designs, including sequins, 
in both TrueView and stitch view. You can view a design, even while digitizing, 
with any number of repeats. See also Viewing design repeats.

Digitizing sequin runs

Use Sequin > Sequin Run Auto to create a string of sequins along a digitized line 
according to current settings.

Use Sequin > Sequin Run Manual to manually digitize sequin-drops along a 
digitized line.
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With Sequin Run you have the option of digitizing individual sequin drops or 
letting the system automatically generate them for you. Digitize lines as you 
would motif runs.

To digitize a sequin run
1 Select a machine format that supports sequin mode via the Select Machine 

Format dialog. 
2 Select the sequin type you want from the Sequin Palette.
 If you have selected a twin-sequin-capable machine, sequin shapes and 

sizes are displayed in pairs.

 Otherwise you have access to single sequins.

3 Click the Sequin Run Auto icon.
4 Digitize the sequin by entering reference points – left-click for corner points, 

right-click for curve points.

5 Press Enter to complete. Sequin drops are automatically generated along 
with their fixing stitches. Spacings can be individually adjusted.

6 To add details or create special spacings, click the Sequin Run Manual icon.

Use Sequin > Sequin Palette to select from a user-defined palette of sequin 
shapes for the current design.

Select sequin pair

Select single sequin

Press Enter

Digitize outline – left-click 
corner points, right-click 
curve points
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7 Digitize individual sequins – again, left-click for corner points, right-click for 
curve points. Connecting and fixing stitches are automatically generated.

Tip  Digitizers sometimes want to generate a sequin run and overlay it with 
a plain run so that sequins are more securely fixed. Another reason for 
backtracking is to avoid jump stitches between objects. The 
Backtrack/Repeat tool is enabled for sequin-run objects. When applied, 
EmbroideryStudio generates manual stitches but leaves other functions 
unaffected.

Related topics
 Selecting a sequin-capable machine
 Creating twin-sequin designs
 Reshaping & editing sequin runs
 Changing sequins & fixing stitches
 Reinforcing outlines
 Adjusting entry/exit points

Changing sequins & fixing stitches

You can select sequins before or after digitizing. Similarly, you can preset fixing 
stitches or change them at any stage.

Press Enter

Digitize individual sequins – 
left-click corner points, 
right-click curve points

Use Sequin > Sequin Palette to select from a user-defined palette of sequin 
shapes for the current design.
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To change sequins and fixing stitches
 To change sequins, select the object and select a different sequin type from 

the Sequin Palette on the Sequin toolbar.

 To change fixing stitches, double-click the object.

 Click the Chooser button in the Fixing field. The docker expands to reveal a 
library containing all the available fixing types.

 Select a fixing stitch type.

Click to open 
Fixing Type 
Chooser

Click to change 
fixing stitch

Choose method for 
setting fixing size

 Fixing stitch
preview

Select fixing
stitch type
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 Press Enter or click Apply.

 To adjust the fixing stitch size, select a method:

 If you have chosen an eccentric sequin type such as ‘ellipse’, fixing stitches 
automatically adapt to fit.

 If you have chosen the manual option, specify a value in the Size field. Size 
is measured from the center of the sequin. Enter a value from 2.50mm to 
30.00mm. 

 If you have chosen automatic matching, specify a margin for the fixing stitch 
in the Margin field. Enter a value from 0.20mm to 2.00mm. This ensures that 
the fixing stitch does not punch too close to the sequin. 

Tip  Sequin Run has potential as a decorative stitch in its own right. For this 
purpose you can select None in the Sequin Palette. This option is best used 
with the Sequin Drop Direction set to Any.

Related topics
 Setting drop-stitch direction

Method Purpose

Match sequin Sets a margin around the sequin so that fixing stitches don’t punch too 
close.

Set manually Allows you to set fixing stitch size regardless of sequin size. The Size 
field is enabled when this option is selected.

Sequin size: 7 mm
Auto margin: 0.50 mm

Sequin size: 7 mm
Manual size: 5.00 mm

Sequin size: 7 mm
Manual size: 10.00 mm
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Adjusting sequin spacing & fixing orientation

You can change sequin spacing at any stage. If you use the manual method, you 
define spacings between sequin-drops with every click you make. If you use the 
automatic method, sequin-drops are calculated according to current settings. 
Fixing stitch orientation can take one of four preset directions – left/right, 
up/down.

To adjust sequin spacing and fixing orientation
1 Select a sequin-run object – manual or automatic.

2 Double-click the object to access object properties.

3 In the Spacing field, enter a nominal spacing. Spacing is measured from the 
center of one sequin to the center of the next.
Enter a value from 1.5mm to 200mm. EmbroideryStudio automatically 
calculates the minimum spacing.

Note  The field is only enabled only if ‘Base’ is selected in the Layer field of 
the same column and the Sequin Run Auto tool selected.

Manual sequin 
run

Automatic 
sequin run

Select positioning 
method

Enter nominal 
spacing
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4 Select a spacing method using the Positioning droplist:

Tip  If you want irregular sequin spacings, digitize with the Sequin Run 
Manual tool. Fine-tune with the Sequin Edit tool.

5 To adjust fixing stitch orientation, place the first stroke in one of the preset 
directions – left/right, up/down:

Related topics
 Reshaping & editing sequin runs

Setting drop-stitch direction

There is an option to ensure that the initial fixing stitch before the sequin drop 
is placed opposite the feeding direction, as recommended by the machine 
manufacturer. Otherwise, the sequin may be deflected by the thread. If the 
needle then misses the center of the sequin because of incorrect placement, the 

Option Purpose

Exact Uses specified spacing. This may result in uneven spacing at the 
end of the path.

Expand to fit Increases nominal spacing to include a sequin at the end of the 
path.

Contract to fit Decreases nominal spacing to include a sequin at the end of the 
path.

Manual Turns the sequin run into a manual object. Performing manual edits 
to sequin-run objects automatically deselects all options. If you 
reset to Exact, Contract to fit, or Expand to fit, all manual edits are 
lost. See also Reshaping & editing sequin runs.

Exact Expand to fit Contract to fit

Choose fixing 
stitch orientation

Orientation: Left Orientation: Right

Orientation: Vertical 
(Up)

Orientation: Vertical 
(Down)
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embroidery material, needle or needle plates may be damaged. In multihead 
machines, sequins are fed from the front or ‘south’ which means that the initial 
fixing stitch or ‘drop stitch’ should be placed on the ‘north’ side (the default). In 
Schiffli machines, the opposite is the case.

To set the drop-stitch direction
1 Select a sequin-run object and double-click to access object properties.

2 Select the drop-stitch direction to ensure that the initial fixing stitch is 
opposite the feeding direction:

Caution  With the Any option, direction is not important. This option 
generates the least number of fixing stitches but may not be suitable for your 
sequin device. Check your machine documentation.

Drop-stitch 
direction

Feeding direction

From north Front or ‘south’ – which is the case in multihead machines.

From south The top or ‘north’ – which is the case in Schiffli machines.

Feeding directionDrop-stitch direction

Select to prevent 
multiple penetrations

Select drop-stitch 
direction

Drop direction ‘From 
South’: initial fixing stitch 
always placed below, and 
sequin fed from ‘north’

Drop direction ‘From
North’: initial fixing stitch

always placed above, and
sequin fed from ‘south’
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3 Enter a Max Angle to specify an angular range within which drop-stitch will 
fall.
You can set the value for either north or south fixing stitches. The default is 
90° but this can be increased or decreased depending on the capabilities of 
your machine.

4 Select the Prevent multiple penetrations option as required.
This option is used to minimize penetrations at the same point, and to 
generate Schiffli-compatible fixing stitching. If you select the Schiffli 
template, the option is ‘on’ by default. When set to ‘off’, some fixing stitches 
will have multiple penetrations at the same point, both at the sequin center 
and outer edge.

5 Select the Closest point join option as required.
By default, this option is off, meaning that the system connects the exit leg 
of the fixing stitch motif, wherever it happens to be, to the entry leg of the 
next fixing stitch motif, again wherever it happens to be. That is, unless the 
connector exceeds the maximum sequin stitch. Choose the Closest point 
join option if you want to always connect fixing stitch motifs from the leg 
closest to the nearest leg of the next fixing stitch motif.

Creating sequin fills

The Sequin Fill feature provides a means of filling complex shapes with sequins 
arranged in columns. The fill can also include a border, with or without a margin. 

Set maximum allowable 
angle for placement of 
fixing stitch

Drop stitch direction 
set to North or South

Prevent Multiple Penetrations on Prevent Multiple Penetrations off
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This can be made from the same or a different sequin and is a property of the 
object.

Sequin fills are tied together by run stitches and travel runs. Travels are placed 
along the object outline. Sequins centers never fall outside the object outline. 
Sequin fixing stitches, however, can lie outside the outline depending on current 
settings.

Tip  The Show Repeats function displays repeating designs, including sequins, 
in both TrueView and stitch view. You can view a design, even while digitizing, 
with any number of repeats. See also Viewing design repeats.

Digitizing sequin fills

Digitizing sequin-fill objects is essentially the same as digitizing complex fill 
objects.

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with sequins.
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Double-clicking a sequin-fill object will invoke these Object Properties.

Controls available on the Fills > Sequin Column Fill tab for patterns and fixing 
stitches are summarized below.

Control Description

Sequin line 
settings

Use these settings to control the overall layout of the fill grid, including 
angle, sequin spacings, and offsets within the grid. See Adjusting sequin 
lines for details.

Fill margin Include a fill margin or not as required. No sequin will have its center 
placed outside the fill margin. Usually used with a border but not 
necessarily. See Adjusting sequin lines for details.

Add border Sequin fills can include a border, with or without a margin. The border is a 
property of the object. See Adding sequin borders for details.

Select Determines what patterns are displayed:
• Sequin Fill: displays the fill pattern
• Sequin Run: displays the border pattern.
All other controls work the same as for Sequin Run. See Creating sequin 
runs for details.

Sequin line settings
control overall layout of

sequin fills

Control fill margin with or
without border

Add a border as
preferred

Control sequin settings
for both fills and borders

Control fixings for both
fills and borders
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Fixing stitches are selected in the same way as for sequin runs. For sequin fills, 
we recommend the simplest fixing stitch available – C01-1. See also Changing 
sequins & fixing stitches.

If you have a twin-sequin capable machine, use the Pattern control to create 
patterned fills. See Creating twin-sequin run patterns for details.

Related topics
 Creating free-form shapes
 Creating twin-sequin designs

Adding sequin borders

Sequin fills can include a border, with or without a margin. The border is a 
property of the object. If a twin-sequin capable machine is selected, the border 
and fill can differ. They can be comprised of single sequins or sequin patterns.

Use the simplest 
fixing stitch
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To add a sequin border
 Select a sequin-fill object and double-click to access object properties.

 Tick the Add Border checkbox and select Sequin Border from the droplist.
 Adjust sequin type as shown. This can be the same or different to the sequin 

fill if you have a twin-sequin capable machine.

 Adjust the fill margin and border spacing as shown.

 Adjust border fixing stitches as for sequin runs. This can be the same or 
different to sequin fills.

Enter nominal
spacing

Click to change
fixing stitch

Adjust fixing stitch size
manually or automatically

Select Sequin Border

Tick border
option

Adjust fill margin

Sequin fill with 
same type border

Sequin fill with 
different type border
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 Set sequin border fixing stitch direction as shown.

Related topics
 Creating twin-sequin run patterns

Adjusting sequin lines

Use sequin line settings to control the overall layout of the fill grid, including 
angle, sequin spacings, and offsets within the grid. 

 Adjust Angle as shown:

Fixing stitch direction: clockwise Fixing stitch direction: counter clockwise

Adjust fixing
stitch direction

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with sequins.

Set margin

Adjust sequin
lines

Independent control of 
column and row spacings

Angle: 45° Angle: 180°
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 Adjust Spacing as shown. This spacing setting controls column spacing, not 
sequin spacing.

 Adjust columns and rows as shown. Sequin Fill provides independent control 
of column and row spacings. Set the nominal spacing in the Spacing field. 
Choose whether you want the fill to fit the grid exactly or to be adjusted 
line-by-line to fit the shape. You have the option of expanding or contracting 
spacings in either or both rows and columns. Each line is adjusted separately. 
The aim is to make sequins follow to the edge of the shape for all lines in the 
fill. This is less important if you add a border to the fill.

 Adjust Offset as shown:

Spacing: 3 mm Spacing: 5 mm

Exact grid 
spacing

Spacing adjusted 
to fit

Offset: 0 mm Offset: 2.5 mm
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 Adjust Direction setting as shown. Sequin lines will run either left-to-right 
(left button) or right-to-left (right button). 

 Activate Add Fill Margin and adjust margin setting as shown. No sequin will 
have its center placed outside the fill margin.

Smoothing edges in sequin fills

Sequin Fill provides independent control of column and row spacings. Set the 
nominal spacing in the Spacing field. Choose whether you want the fill to fit the 
grid exactly or to be adjusted line-by-line to fit the shape. You have the option 
of expanding or contracting spacings in either or both rows and columns. Each 

Layout: 
left-to-right

Layout: right-to-left

Sequin fill with fill 
margin

Sequin fill with hole 
and fill margin

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with sequins.
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line is adjusted separately. The aim is to make sequins follow to the edge of the 
shape for all lines in the fill. This is less important if you add a border to the fill.

Adjusting patterns & fixing orientation

If you have a twin-sequin capable machine, you can use the Pattern control to 
create patterned borders and/or fills. Use it also to control sequin spacing 
independently of line spacing. If you use the manual method, you define 
spacings between sequin-drops with every click you make. If you use the 
automatic method, sequin-drops are calculated according to current settings. 
Fixing stitch orientation can take one of four preset directions – left/right, 
up/down. Most controls work the same as for Sequin Run.

Independent control of 
column and row spacings

Exact grid 
spacing

Spacing adjusted 
to fit
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To adjust patterns and fixing orientation
1 Select a sequin-fill object and double-click to access object properties.

2 In the Patterns pane, adjust spacings for fill and/or border as required.
Spacing is measured from the center of one sequin stack to the center of the 
next.

Note  When the field is enabled, you can enter a value from 1.5mm to 
200mm, but EmbroideryStudio automatically calculates the minimum 
spacing allowed. 

3 To adjust fixing stitch orientation, place the first stroke in one of the preset 
directions – left/right, up/down:

Set up sequin
patterns for fills
and/or borders

Adjust sequin
fixing stitching

Enter nominal 
spacing

Fill spacing: 4
Border spacing: 6

Fill spacing: 5.5
Border spacing: 4.5

Fill spacing: 7
Border spacing: 3

Choose fixing 
stitch orientation

Orientation: vertical (up) Orientation: vertical (down)
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Tip  If you have a twin-sequin capable machine, you can use the Patterns 
control to create patterned fills.

Related topics
 Creating twin-sequin designs

Creating twin-sequin designs

EmbroideryStudio supports the creation of twin-sequin designs for 
twin-sequin-capable machines. Twin-sequin mode has several advantages over 
the standard single-sequin mode. It allows you to create and visualize 
predefined patterns of sequin runs comprising pairs of sequins of different size, 
color, and shape. This in turn allows you to create twin-sequin designs and 
output machine files to twin-sequin-capable machines.

Tip  Twin-sequin mode also allows you to convert vector objects to twin-sequin 
outlines. See also Converting sequin artwork.

Setting up twin-sequin palettes

Use Sequin > Sequin Palette Editor to select shapes from a sequin library. 
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The Sequin Palette Editor lets you prepare a palette of sequins to use in your 
design. Once set up, the palette is available for use from the Sequin Palette 
droplist.

To set up a twin-sequin palette
1 Select a machine format that supports twin-sequin mode via the Select 

Machine Format dialog.

2 Open the Sequin Palette Editor and create the palette you want to use. 
Default sequin pairs appear in Columns #1 and #2. The only difference when 
you set up a palette in twin-sequin mode is that you set up sequin pairs rather 
than single sequins.

 Sequin shapes are now available for selection from the Sequin Palette. 
Sequin shapes and sizes are displayed in pairs.

Related topics
 Selecting a sequin-capable machine

Choosing twin-sequin patterns

Select
twin-sequin-capable

machine format

Click to add 
sequin pairs

Twin sequin pairs
added by default

Twin-sequin palette

Use Sequin > Sequin Palette Editor to select shapes from a sequin library.

Use Docker > Object Properties to toggle the Object Properties docker on/off. Use 
it to set properties for the current design.



   Sequin Digit iz ing 25

EmbroideryStudio allows you to select twin-sequin patterns from a pattern 
library. These can be applied to existing twin-sequin objects or newly created 
objects.

To choose a twin-sequin pattern
1 Open Object Properties and go to the Outlines > Sequin Run tab. A 

Pattern table allows you to set a pattern of sequin drops for the currently 
selected pair.

2 Click the Patterns button to select a preset pattern from the library. The 
Sequin Pattern dialog opens.

3 Choose from the Sequin Pattern droplist. A preview is displayed.
4 Click Apply Pattern to make the selected pattern current. The pattern is also 

immediately applied to any selected sequin-run objects.

PeackockPattern3

Alternate Twin Overlap

Group of 3 + Single

Twin Lace

PeackockPattern1

PeackockPattern2

Select preset
patterns from a

pattern library

Click to select pattern
from droplist

Preview of
selected pattern

Make selected 
pattern current
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5 Using the Sequin Run Auto or Sequin Run Manual tools, create your 
twin-sequin runs.

6 Select another sequin pair and continue digitizing. The same pattern will 
apply until you change it.

Related topics
 Selecting a sequin-capable machine
 Setting up sequin mode
 Digitizing sequin runs

Adjusting twin-sequin runs

Change patterns applying to twin-sequin runs like any other object properties. 
You can apply current properties to selected objects, apply other sequin pairs, 
and/or different patterns. You can even define you own patterns.

To adjust twin-sequin runs
 Create or select a twin sequin-run object.

Tip  You can convert a normal run to sequin run by selecting and clicking the 
Sequin Run Auto tool.

Use Sequin > Sequin Run Auto to create a string of sequins along a digitized line 
according to current settings.

Use Sequin > Sequin Palette to select from a user-defined palette of sequin 
shapes for the current design.
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 To change sequin shapes, select another pair from the Sequin Palette.

 To change twin-sequin patterns, double-click the object to open Object 
Properties.

 Click the Patterns button.

 Choose from the Sequin Pattern droplist. A preview is displayed.
 Click Apply Pattern to apply the selected pattern.

The pattern is immediately applied to the selected sequin-run object.

Select a pattern

Click to select
pattern from

droplist

Preview of
selected pattern

Click to apply 
selected 
sequin pair

Select alternative
sequin pair
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 Optionally, select a different sequin pair from the Preview Panel droplist and 
click Apply Sequin. The selected sequin pair, using the same pattern, is 
applied.

 Optionally, use the Pattern table in the Object Properties docker to define 
your own twin-sequin pattern. This allows you to set a pattern of sequin drops 
for the currently selected sequin pair.

 Optionally, make a selected object’s properties current, including twin-sequin 
patterns, and apply them to existing objects.

Related topics
 Digitizing sequin runs
 Creating twin-sequin designs
 Copying properties

Creating twin-sequin run patterns

EmbroideryStudio lets you create custom twin-sequin run patterns and, 
optionally, save them to a pattern library for later use.

To create a twin-sequin run pattern
1 Select a machine format that supports twin-sequin mode via the Select 

Machine Format dialog.
2 Create a twin-sequin-run object with the Sequin Run Auto tool or Sequin 

Run Manual tool.

Change sequin pairs

Copy and paste 
twin-sequin patterns from 
one object to another

Use Docker > Object Properties to toggle the Object Properties docker on/off. Use 
it to set properties for the current design.
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Alternatively, select an existing twin-sequin-run object so that you can 
preview your pattern as you create it.

3 Select the pair you want to use for your twin-sequin pattern.

4 Open Object Properties.
By default, the left sequin of the topmost pair in the sequin palette list is 
displayed in column #1 of the table.

5 Add more sequins to the pattern via the Add Sequin (+) button.
A new column is added to the table. Delete any unwanted sequins in the 
pattern by clicking the X at the right of the column header.

6 Select a sequin from the droplist.
7 In the Layer field, specify whether the sequin is to be stacked (‘on top’) or 

to form a new element (‘base’).

Select sequin pair

Add sequins to pattern

Click to change 
fixing stitch

Click to change sequin

Define parameters
for each sequin in

the pattern

Set sequin 
placement – ‘base’ 
or ‘on top’
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Tip  Click the Apply button or press Enter to preview your settings with the 
selected twin-sequin-run object.

8 In the Spacing field, enter a nominal spacing.
Spacing is measured from the center of one sequin to the center of the next.

9 In the Fixing field, select the type of fixing you want.
To adjust fixing stitch orientation, place the first stroke in one of the preset 
directions – left/right, up/down.

10 When satisfied with the twin-sequin run pattern you have defined, click the 
Save icon next to the Patterns button.

11 Enter a name for the new pattern and click OK. The pattern is now available 
for use in the Sequin Pattern dialog.

Related topics
 Selecting a sequin-capable machine
 Digitizing sequin runs
 Changing sequins & fixing stitches
 Adjusting sequin spacing & fixing orientation
 Choosing twin-sequin patterns

Creating twin-sequin fill patterns

EmbroideryStudio lets you create custom twin-sequin fill patterns. The process 
is essentially the same as creating a custom twin-sequin run pattern, except you 
can’t save it for later use.

Enter nominal spacing

Adjust fixing stitch

Enter pattern
name

My Pattern

Use Docker > Object Properties to toggle the Object Properties docker on/off. Use 
it to set properties for the current design.
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Open Object Properties and define a fill pattern as you would for a sequin run.

Change sequin pairs as desired.

Pattern stamp re-coloring of twin-sequin fills

Sequin Fill can be used in combination with Carving Stamp to digitize sequin 
fills with predefined twin sequin assignments. The stamp pattern takes the color 
of the other sequin in the currently selected pair.

Define fill 
pattern

Select sequin pair

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with sequins.

Use Docker > Carving Stamp to define a pattern of needle penetrations using a 
‘carving stamp’ as a template.

Select sequin pair
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Related topics
 Creating patterns with carving stamps

Converting objects to sequins

Most objects in EmbroideryStudio are inter-convertible. Open and closed 
sequin objects are no exception. Any open object – Run, Stemstitch, Motif Run, 
Freehand, Column C, Vector – can be quickly converted to sequin run. Similarly, 
any closed object – Column A/B, Complex Turning, or Complex – can be 
converted to sequin fill. EmbroideryStudio also provides a dedicated tool for 
automatically converting sequin artwork in the form of a vector file to sequin 
runs. 

Converting embroidery objects to sequins

Convert any open object – Run, Stemstitch, Motif Run, Freehand, Column C, 
Vector – to sequin run.

Use Sequin > Sequin Run Auto to create a string of sequins along a digitized line 
according to current settings.

Use Sequin > Sequin Fill to digitize and fill large, irregular shapes with sequins.
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Right-click and select Convert > Convert to Sequin Run. Alternatively, click 
the Sequin Run Auto icon.

Similarly, convert any closed object – Column A/B, Complex Turning, or Complex 
– to sequin fill.

Right-click and select Convert > Convert to Sequin Fill. Or click the Sequin 
Fill icon.

Converting sequin artwork

Frequently, artwork for sequin designs is independently created by a specialist 
designer and supplied to the embroidery digitizer as a vector file. The Vectors 
to Sequins tool is available for just this purpose. A sequin run is automatically 
created from a set of vector objects representing sequins. Fixing stitches are 
generated automatically according to current settings. If you are digitizing 
twin-sequin runs, EmbroideryStudio will generate sequin drops according to 
the currently selected sequin run pattern.

Use Sequin > Vectors to Sequins to create a sequin run from a set of sequin vector 
objects selected by intersecting line.
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To convert sequin artwork
1 Select a machine format that supports sequin mode via the Select Machine 

Format dialog. 
2 Insert the sequin artwork into the design.

Properly designed artwork will contain vector objects centered on the exact 
locations required for sequins in the design.

3 Select the sequin type you want to use from the droplist in the Sequin 
Palette.

4 Select the Vectors to Sequins icon.
5 Click the sequin graphic which will start the sequin run.

6 Digitize a line connecting all sequins to be included in the sequin run.
The line only needs to touch the sequin object somewhere within its 
boundary. Left-click for corner points, right-click for curve points.

7 Press Enter.
A sequin run is generated along a curve that passes through the center of 
each sequin graphic with sequin objects positioned at these centers. Current 
properties are applied and the object is set to ‘manual’ by default. The 
generated curve contains a reshape node at each sequin position.

Select single sequin

Digitize connecting
line passing through

all sequin graphics

Sequin Run
automatically generated

Reshape nodes generated
at each sequin drop
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Tip  If you are running twin-sequin mode and preset a sequin pattern in 
Object Properties, this pattern is applied to the converted sequin objects 
while sequin spacing is preserved as per the artwork.

Related topics
 Choosing twin-sequin patterns
 Selecting a sequin-capable machine
 Creating twin-sequin designs

Modifying sequin designs

Sequin-fill objects can be reshaped like any other embroidery object. Adjustable 
column layout parameters include column spacing, angle, and offset.

Reshaping & editing sequin runs

You have complete control over scaling and reshaping sequin-run objects. Scale 
and reshape sequin run lines, as well as remove or add individual sequins. You 

Pattern applied

Use Select Tools > Select Object to resize objects using selection handles.

Use Reshape Tools > Reshape Object to reshape selected sequin-run objects.

Use Sequin > Sequin Edit to fine-tune placement of individual sequins.
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can also manually fine-tune sequin spacings. You can even edit individual fixing 
stitches.

Note  Performing manual edits to sequin-run objects automatically deselects all 
options. If you reset to Exact, Contract to fit, or Expand to fit, all manual 
edits are lost.

To reshape and edit a sequin run
 Scale sequin-run objects by clicking and dragging selection handles, or by 

adjusting general properties. 
 If the object is created with the Sequin Run Auto tool, the sequin drops 

are automatically recalculated.

 If the object is created with the Sequin Run Manual tool, the original 
number of sequin drops is preserved.

 Reshape sequin run lines with the Reshape tool. Add reshape nodes by left- 
or right-clicking the outline.

Sequin drops
regenerated according

to current settings

Original number of
sequin drops

preserved
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 Fine-tune individual sequin spacings with the Sequin Edit tool – 
click-and-drag a diamond control point. Hold down Shift or Ctrl keys to select 
a range or multiple control points. 

 Delete selected sequins by pressing Delete.

 Add sequins by holding down the Alt key and clicking the sequin run line.
If you are running twin-sequin mode, you have the option of selecting 
alternative sequins from the droplist.

 If you are running twin-sequin mode, right-click a diamond control point while 
modifying a particular sequin. Options include: removing the sequin, 
replacing it, adding another sequin on top or underneath it:

Related topics
 Scaling objects
 Reshaping embroidery objects

Click-and-drag
spacing handle

Click a diamond control 
point and press Delete

Hold down Alt key
and click Select a sequin type 

from the popup menu

Replace sequin with 
selection from menu
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Reshaping & editing sequin fills

Either by means of object properties or the Reshape Object tool, you can 
control the overall shape of sequin fills as well as their layout. You can also set 
entry and exit points to avoid excessive needle penetrations.

To reshape and edit a sequin fill
 Select a sequin-fill object and click the Reshape icon.

 Adjust overall shape like any embroidery object.

Use Reshape Tools > Reshape Object to reshape selected objects by means of 
control points.

Use Sequin > Sequin Edit to fine-tune placement of individual sequins.

Use reshape nodes 
to reshape outline
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 Use the three central control points to adjust sequin line settings interactively. 
These control Direction Angle, Spacing, and Offset settings. Pattern 
spacing is also influenced.

Pattern spacing is also controlled numerically via the Patterns panel.

 Adjustments can cause needle penetrations to occur within sequins. Affected 
sequins are highlighted in pink. Adjust layout and/or entry/exit points to 
minimize unwanted needle penetrations.

 Fine-tune individual sequin spacings with the Sequin Edit tool – 
click-and-drag a diamond control point.

Adjust sequin line settings 
interactively

Needle 
penetrations

Line Spacing: 3mm
Offset: 1mm

Line Spacing: 5mm
Offset: 4mm

Line Angle: 125°
Pattern Spacing: 8mm

Set entry and exit points to 
minimize excessive 
needle penetrations
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 Holes can be digitized in sequin-fill objects in the same way as any free shape.

Related topics
 Reshaping embroidery objects
 Adjusting patterns & fixing orientation
 Reshaping & editing sequin runs
 Creating free-form shapes

Creating custom sequins

EmbroideryStudio supports sequin shapes with offset holes. Such sequin 
shapes can be utilized for flipping sequins on the fabric to form two different 
sequin fill patterns. 

Custom sequin shapes & hole positions
The software allows you to define your own shapes with their own hole position 
and size. Create you own sequin shapes with vectors. The Ring tool is useful for 
this.

Sequin fills can 
contain holes

Position hole as 
required
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Position the hole. Size the sequin to a nominal size. Select and choose Object 
> Create Sequin Shape. Overlap allowance is automatically adjusted to 
accommodate different hole positions.

Saving custom sequins involves the same steps as saving custom motifs. Choose 
a sequin set or create a new one. Give your sequin a name and click OK to save. 
The custom sequin is available from the sequin droplist for use in sequin 
palettes.

Custom sequin fixings
Similarly, there is a capability to define custom fixing stitches to support 
multi-head sequin devices. Some limitations might exist for older more 
complicated sequin devices. Access the dialog via the Object menu.

Benefits of user-defined sequin fixings include:
 Create multiple layers of stitching for decorative effects, sometimes in 

different thread colors (Barudan).
 Reduce stitch counts in large sequin designs.
 Accommodate specific fixing requirements.
 Accommodate new capabilities – e.g. offset holes.

Save your own
sequin shapes

Follow
instructions

Name your
fixing stitch

Set angle to define
snap lines

Custom fixing stitch
added to library
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Tip  If you have chosen an eccentric sequin type such as ‘ellipse’, fixing stitches 
automatically adapt to fit.

Related topics
 Digitizing stars & rings

Digitizing individual sequin drops

If you require precise control over the positioning and encoding of your sequin 
drops, EmbroideryStudio provides manual techniques for this purpose.

Digitize sequin drops with fixings

The Manual Sequin input method allows you individual 
control over sequin placement and fixing stitches. 
Create decorative outlines and patterns manually using 
sequins from the selection list. To add a sequin to the 
stitching sequence, simply drop it onto the design and 
secure it with manual stitches. Manual sequin stitching 
is a difficult digitizing skill to master and you need to 
plan the stitching sequence carefully in order to 
minimize unnecessary stitches. Experiment with your 
machine and stitch width and spacing settings to achieve 
the desired result.

Note  Sequin mode is supported in Schiffli, Tajima, 
Barudan and ZSK embroidery machine formats. Before 
you can use Sequin mode, you must select a machine 
format that supports it. Similarly, before you can use 
Twin-Sequin mode, you must select a suitable machine 
format. See Selecting a sequin-capable machine for details. See Creating 
twin-sequin designs for details.

Use Sequin > Manual Sequin to digitize individual sequins.

Use Sequin > Left Sequin to switch to left sequin when digitizing twin-sequin 
designs.

Use Sequin > Right Sequin to switch to right sequin when digitizing twin-sequin 
designs.
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To digitize a sequin drop with fixing stitches
 Select a machine format that supports sequin mode via the Select Machine 

Format dialog. See Selecting a sequin-capable machine for details.
 Click the Manual Sequin icon.
 If you have activated Twin-Sequin mode, sequin shapes are displayed in 

pairs. Left and Right Sequin icons are both available.

 Otherwise, you will have access to single sequins. Only the Left icon is 
available.

 Left-click to begin your manual sequin run. It must start with at least one 
stitch.

 Right-click to drop a sequin. A sequin outline appears.
 Left-click to digitize fixing stitches around the sequin to secure it.

Three stitches in the shape of a ‘Y’ are generally used. The needle points of 
each stitch must be placed precisely to ensure that sequins are not pierced 
by the needle when stitching.

Tip  Zoom in for more accurate digitizing.

Select sequin pair

Select sequin to use

Left-click to digitize fixing stitches

Right-click to ‘drop’ sequin

Continue digitizing – right-click for 
sequin drops, left-click for fixing 
stitches
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 If you have activated Twin-Sequin mode, click the Right Sequin button to 
switch sequins. Alternatively, press the Tab key to switch between left and 
right sequins while digitizing.

 Continue digitizing manually in the same way – right-click to add a sequin, 
left-click to digitize fixing stitches. Press Enter to finish.

Related topics
 Selecting a sequin-capable machine
 Setting up sequin mode

Digitize sequin drops while traveling

In preference to the Manual Sequin tool, some users prefer to flesh out a 
design using Run or Triple Run stitching and then travel through it, dropping 
sequins manually as and where required. This technique can be used with single 
or twin sequins.

To digitize sequin drops while traveling
 Select a machine format that supports sequin mode via the Select Machine 

Format dialog. See Selecting a sequin-capable machine for details.

Use Traditional Digitizing > Run to place a row of single run stitches along a 
digitized line. Right-click for settings.

Use Travel > Travel 1 Stitch to move stitch cursor forwards/backwards 1 stitch at a 
time. Left/right click.

Use Sequin > Drop Sequin to drop a sequin at the current needle position. For 
twin-sequin machines, left-click to drop a left-sequin, right-click to drop a 
right-sequin.

Use Sequin > Clear Function to remove any sequin functions from the current 
needle position.

Use Traditional Digitizing > Backtrack to reinforce an outline, stitching it in the 
reverse direction to the original.
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 Set a fixed run length to suit the type of sequin/s you are using.

 Choose a digitizing method to create the design or pattern you want.
 Press the Home button and travel through the design using arrow keys or 

Travel tools.
 Press the ‘hotkey’ 5 to drop a sequin at a particular stitch. Alternatively, click 

the Drop Sequin button.

 If you are using twin sequins, press the hotkey 6 to drop the other sequin. 
Alternatively, right-click the Drop Sequin button.

 If you want to delete a sequin drop, travel to the location and press 4 to 
delete the sequin from current stitch. Alternatively, click the Clear Sequin 
button.

Tip  If you are using Triple Run, the repeat stitch will tack down your sequin 
drop. If you are using Single Run, you can use the Backtrack tool to tack 
down the sequin drops.

Insert sequin drop functions

You can insert machine functions manually by means of the Insert Function 
dialog. Depending on your machine’s requirements, you will either add the 
function to the current stitch, or insert it on an empty stitch or empty jump.

To insert sequin drop functions
1 Select a machine format that supports sequin mode via the Select Machine 

Format dialog. See Selecting a sequin-capable machine for details.
2 Travel to the position in the design where you want to insert a machine 

function.

Set run length to suit 
sequins

Press hotkey to
‘drop’ a sequin
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3 Select Function > Insert Function. The Insert Function dialog opens.

Tip  Depending on your machine, you may need to insert additional empty 
stitches or empty jumps before or after the selected function. For example, 
before a particular Stop function, you may want to insert a number of empty 
jumps. See your machine manual for details.

4 From the Available Functions list, select the Drop Sequin function.
5 Choose the insertion method – Insert on Empty Stitch or Add to Current 

Stitch. 
6 To insert additional empty stitches or empty jumps, select one or other in the 

Component field and click Insert Before or Insert After as required. 
7 When your Drop Sequin function has been correctly defined, click OK. The 

Twin Device - Select Sequin dialog is displayed.

8 Click Left or Right buttons to activate left or right sequins on the sequin 
dispenser. The Sequin Drop function, together with any additional empty 
stitches or jumps, is added at the current needle position.

Tip  The Stitch List provides an alternative means for inserting machine 
functions manually. 

Related topics
 Inserting machine functions manually
 Traveling through designs
 Selecting & editing stitches

Select Drop
Sequin function

Choose left or right 
sequin on sequin 
dispenser
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