Does ES support Windows on Mac with Apple M1 / M2 chip using Parallels Desktop.

Does ES support Windows on Mac with Apple M1 / M2 chip using Parallels Desktop.

ES e4.5 : 

Yes, the following combination has been tested running ES e4.5 in a Mac M1 environment.

Latest ES e4.5 installation from the main help page announcements.

Windows 11 Home / Pro - 22H2 ARM Edition

Parallels Desktop 18 for Mac 

MacBook Pro 13 Inch M1 - 16GB RAM - macOS Monterey Version 12.1

CorelDraw Graphics Suite 2020 - Version 22.1.0.517


ES  Digital Edition : 

Support for Digital Edition is not available at the moment, Digital Edition will currently not support MAC / Parallels.

It is very important to install the latest patches/versions or the system may not operate correctly.

Please note not all functionality has been tested in this environment, if there are any issues please report them to Wilcom Support.

 


    • Related Articles

    • Wilcom Technical Support Policy

      Wilcom Technical Support Policies Overview Wilcom are committed to ensuring that our customers get the most from their Wilcom software. For this reason, we offer a comprehensive range of support and training offerings, in many cases including free ...
    • How To Set the Default GPU for Applications - ES

      In some laptops or desktops they are supplied with 2 graphics processors one is normally a on-board lower end GPU while the other is a more higher performance GPU. ES should be set to use the high performance card as it is an graphics intensive ...
    • EmbroideryConnect Support Note

      Access the EmbroideryConnect Support Note documentation. Read the Support Note now »
    • ES crashing when launching CorelDRAW on a second monitor

      Problem: Wilcom EmbroideryStudio crashes when switching to CorelDRAW on a second monitor (non-primary) Solution: Please follow the steps accordingly: Start ES on your primary monitor Right-click on the toolbar icon, then mouseover "Wilcom ...
    • What CorelDRAW version can be integrated with ES e4.5?

      EmbroideryStudio e4.5 is compatible with the following CorelDRAW® products ONLY. CorelDRAW® Graphic Suite 2017 version/build 19.1.0.419 - Bundled with ES e4 CorelDRAW® Graphic Suite 2020 version/build 22.1.0.517 - Bundled with ES e4 CorelDRAW® ...